Q
Problem solve Get help with specific problems with your technologies, process and projects.

Missing header in ALV

I'm an SAP ABAP developer in the states and have recently developed a report using ALV. I used the function module...

REUSE_ALV_GRID_DISPLAY to display the output and this used to display header information that I passed, until just recently. I'm not sure what changes were made to the system but the entire source has not changed. I tried to debug and find why it's not displaying the header, but gave up after intensive hobbling around in debug. I changed the Function Module to REUSE_ALV_LIST_DISPLAY and it now displays the heading, but I'd still like to find out why.

Can you help?

It occurs to me that the REUSE_ALV_GRID_DISPLAY is for the ALV grid - the EnjoySAP control, but REUSE_ALV_LIST_DISPLAY is for the ALV. Perhaps that is why you are experiencing odd behaviour. Although the ALV Grid and the ALV are very similar in use, they are not the same.

This was last published in June 2004

Dig Deeper on SAP Basis administration and NetWeaver administration

PRO+

Content

Find more PRO+ content and other member only offers, here.

Have a question for an expert?

Please add a title for your question

Get answers from a TechTarget expert on whatever's puzzling you.

You will be able to add details on the next page.

Start the conversation

Send me notifications when other members comment.

By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Please create a username to comment.

-ADS BY GOOGLE

SearchManufacturingERP

SearchOracle

SearchDataManagement

SearchAWS

SearchBusinessAnalytics

SearchCRM

SearchContentManagement

SearchFinancialApplications

Close